Salt Bank - Plati din aplicatie nefunctionale. – Incident details
Get updates
Email
Get updates
Dark mode
Language
All systems operational
Plati din aplicatie nefunctionale.
Resolved
Major outage
Started 24 days ago
Lasted about 1 hour
Affected
Instant Payments
Major outage from 3:20 PM to 4:49 PM
Updates
Resolved
April 02, 2025 at 4:49 PM
Resolved
April 02, 2025 at 4:49 PM
Incidentul a fost rezolvat.
Investigating
April 02, 2025 at 3:20 PM
Investigating
April 02, 2025 at 3:20 PM
We are currently investigating this incident.