Salt Bank - Login not operational. – Incident details
Get updates
Email
Get updates
Dark mode
Language
All systems operational
Login not operational.
Resolved
Major outage
Started 10 months ago
Lasted 17 minutes
Affected
Login
Operational from 12:04 PM to 12:20 PM
Updates
Resolved
July 02, 2025 at 12:20 PM
Resolved
July 02, 2025 at 12:20 PM
This incident has been resolved.
Investigating
July 02, 2025 at 12:04 PM
Investigating
July 02, 2025 at 12:04 PM
We are currently investigating this incident.