Salt Bank - Utility bills unavailable on Android – Incident details

All systems operational

Utility bills unavailable on Android

Resolved
Partial outage 30 %
Started 2 days agoLasted about 3 hours

Affected

Utility bills

Partial outage from 7:17 PM to 10:12 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    Currently, we are investigating this incident. Impact is only on Android users.